package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[Hh]eading\t(\d+)\t[\d\.]+\t(.+)`)
var str = `heading 1 0. References
heading 1 1. Introduction
heading 1 2. System of interest: heavy component
heading 2 2.1 Definition and role of the heavy component
heading 3 2.1.1 General Definitions
heading 3 2.1.2 heavy component main missions
heading 11 2.1.1.11.3.4 Generic chapter
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}