const regex = /^[Hh]eading\t(\d+)\t[\d\.]+\t(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[Hh]eading\\t(\\d+)\\t[\\d\\.]+\\t(.+)', 'gm')
const str = `heading 1 0. References
heading 1 1. Introduction
heading 1 2. System of interest: heavy component
heading 2 2.1 Definition and role of the heavy component
heading 3 2.1.1 General Definitions
heading 3 2.1.2 heavy component main missions
heading 11 2.1.1.11.3.4 Generic chapter
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}