#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[Hh]eading\t(\d+)\t[\d\.]+\t(.+)"
Local $sString = "heading 1 0. References" & @CRLF & _
"heading 1 1. Introduction" & @CRLF & _
"heading 1 2. System of interest: heavy component" & @CRLF & _
"heading 2 2.1 Definition and role of the heavy component" & @CRLF & _
"heading 3 2.1.1 General Definitions" & @CRLF & _
"heading 3 2.1.2 heavy component main missions" & @CRLF & _
"heading 11 2.1.1.11.3.4 Generic chapter" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")