re = /const\s+(?<c>[a-z][a-z\d_]*)\s*=\s*(?<q>["'])(?<v>(?:\\\k<q>|(?!\k<q>).)*)(?:\k<q>)\s*;/i
str = 'const SIMPLE = "simple";
const WITH_S_QUOTE = "exam \\" with quote";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end