import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "const\\s+(?<c>[a-z][a-z\\d_]*)\\s*=\\s*(?<q>[\"'])(?<v>(?:\\\\\\k<q>|(?!\\k<q>).)*)(?:\\k<q>)\\s*;";
final String string = "const SIMPLE = \"simple\";\n"
+ "const WITH_S_QUOTE = \"exam \\\" with quote\";";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}