const regex = /const\s+(?<c>[a-z][a-z\d_]*)\s*=\s*(?<q>["'])(?<v>(?:\\\k<q>|(?!\k<q>).)*)(?:\k<q>)\s*;/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('const\\s+(?<c>[a-z][a-z\\d_]*)\\s*=\\s*(?<q>["\'])(?<v>(?:\\\\\\k<q>|(?!\\k<q>).)*)(?:\\k<q>)\\s*;', 'gi')
const str = `const SIMPLE = "simple";
const WITH_S_QUOTE = "exam \\" with quote";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}