using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"const\s+(?<c>[a-z][a-z\d_]*)\s*=\s*(?<q>[""'])(?<v>(?:\\\k<q>|(?!\k<q>).)*)(?:\k<q>)\s*;";
string input = @"const SIMPLE = ""simple"";
const WITH_S_QUOTE = ""exam \"" with quote"";";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}