$re = '/const\s+(?<c>[a-z][a-z\d_]*)\s*=\s*(?<q>["\'])(?<v>(?:\\\\\k<q>|(?!\k<q>).)*)(?:\k<q>)\s*;/i';
$str = 'const SIMPLE = "simple";
const WITH_S_QUOTE = "exam \\" with quote";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);