#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)const\s+(?<c>[a-z][a-z\d_]*)\s*=\s*(?<q>["'])(?<v>(?:\\\k<q>|(?!\k<q>).)*)(?:\k<q>)\s*;"
Local $sString = "const SIMPLE = "simple";" & @CRLF & _
"const WITH_S_QUOTE = "exam \" with quote";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")