# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^Fuse - )[\d.\/m]+A|(?<=\s)\dA"
test_str = ("Fuse - 1.25A 250V 5x20mm, Glass, Time Delay, 5/pk\n"
"Fuse - 1A 250V 5x20mm, Glass, Time Delay, 5/pk\n"
"Fuse - 20A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style\n"
"Fuse - 3/4A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style\n"
"Fuse - 340mA 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style\n"
"SCR - 4A 400V T0126")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.