$re = '/(?<=^Fuse - )[\d.\/m]+A|(?<=\s)\dA/m';
$str = 'Fuse - 1.25A 250V 5x20mm, Glass, Time Delay, 5/pk
Fuse - 1A 250V 5x20mm, Glass, Time Delay, 5/pk
Fuse - 20A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
Fuse - 3/4A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
Fuse - 340mA 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
SCR - 4A 400V T0126';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);