using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^Fuse - )[\d.\/m]+A|(?<=\s)\dA";
string input = @"Fuse - 1.25A 250V 5x20mm, Glass, Time Delay, 5/pk
Fuse - 1A 250V 5x20mm, Glass, Time Delay, 5/pk
Fuse - 20A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
Fuse - 3/4A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
Fuse - 340mA 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
SCR - 4A 400V T0126";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}