#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^Fuse - )[\d.\/m]+A|(?<=\s)\dA"
Local $sString = "Fuse - 1.25A 250V 5x20mm, Glass, Time Delay, 5/pk" & @CRLF & _
"Fuse - 1A 250V 5x20mm, Glass, Time Delay, 5/pk" & @CRLF & _
"Fuse - 20A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style" & @CRLF & _
"Fuse - 3/4A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style" & @CRLF & _
"Fuse - 340mA 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style" & @CRLF & _
"SCR - 4A 400V T0126"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")