const regex = /(?<=^Fuse - )[\d.\/m]+A|(?<=\s)\dA/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^Fuse - )[\\d.\\\/m]+A|(?<=\\s)\\dA', 'gm')
const str = `Fuse - 1.25A 250V 5x20mm, Glass, Time Delay, 5/pk
Fuse - 1A 250V 5x20mm, Glass, Time Delay, 5/pk
Fuse - 20A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
Fuse - 3/4A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
Fuse - 340mA 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style
SCR - 4A 400V T0126`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}