import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^Fuse - )[\\d.\\/m]+A|(?<=\\s)\\dA";
final String string = "Fuse - 1.25A 250V 5x20mm, Glass, Time Delay, 5/pk\n"
+ "Fuse - 1A 250V 5x20mm, Glass, Time Delay, 5/pk\n"
+ "Fuse - 20A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style\n"
+ "Fuse - 3/4A 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style\n"
+ "Fuse - 340mA 250V 5x20mm, Glass, Time Delay, 5/pk MDA Style\n"
+ "SCR - 4A 400V T0126";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}