re = /^([#$%*& ])(?<name>[A-Za-z]+)\1=(?<length>[0-9]+)!!(?<code>.*$)/m
str = 'Mike??Hailwood=5!![pliu
#SteveHislop#=16!!df%TU[Tj(h!!TT[S
*DavMolyneux*=15!!efgk#\'_$&UYV%h%
RichardQ^uayle=16!!fr5de5kd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end