import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([#$%*& ])(?<name>[A-Za-z]+)\\1=(?<length>[0-9]+)!!(?<code>.*$)";
final String string = "Mike??Hailwood=5!![pliu\n"
+ "#SteveHislop#=16!!df%TU[Tj(h!!TT[S\n"
+ "*DavMolyneux*=15!!efgk#'_$&UYV%h%\n"
+ "RichardQ^uayle=16!!fr5de5kd\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}