$re = '/^([#$%*& ])(?<name>[A-Za-z]+)\1=(?<length>[0-9]+)!!(?<code>.*$)/m';
$str = 'Mike??Hailwood=5!![pliu
#SteveHislop#=16!!df%TU[Tj(h!!TT[S
*DavMolyneux*=15!!efgk#\'_$&UYV%h%
RichardQ^uayle=16!!fr5de5kd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);