#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([#$%*& ])(?<name>[A-Za-z]+)\1=(?<length>[0-9]+)!!(?<code>.*$)"
Local $sString = "Mike??Hailwood=5!![pliu" & @CRLF & _
"#SteveHislop#=16!!df%TU[Tj(h!!TT[S" & @CRLF & _
"*DavMolyneux*=15!!efgk#'_$&UYV%h%" & @CRLF & _
"RichardQ^uayle=16!!fr5de5kd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")