use strict;
my $str = 'Mike??Hailwood=5!![pliu
#SteveHislop#=16!!df%TU[Tj(h!!TT[S
*DavMolyneux*=15!!efgk#\'_$&UYV%h%
RichardQ^uayle=16!!fr5de5kd
';
my $regex = qr/^([#$%*& ])(?<name>[A-Za-z]+)\1=(?<length>[0-9]+)!!(?<code>.*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}