using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([#$%*& ])(?<name>[A-Za-z]+)\1=(?<length>[0-9]+)!!(?<code>.*$)";
string input = @"Mike??Hailwood=5!![pliu
#SteveHislop#=16!!df%TU[Tj(h!!TT[S
*DavMolyneux*=15!!efgk#'_$&UYV%h%
RichardQ^uayle=16!!fr5de5kd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}