import Foundation
let pattern = #"[ \t]*(\+|\-)?[ \t]*(\d*\.?\d+(E[\+|\-|\d]\d*)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
4.948601281E-4
34.6
12
23E+4
12.45E5
-12.34E-5i
4.948601281E-4-11.34E-4i
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)