#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[ \t]*(\+|\-)?[ \t]*(\d*\.?\d+(E[\+|\-|\d]\d*)?)"
Local $sString = "4.948601281E-4" & @CRLF & _
"34.6" & @CRLF & _
"12" & @CRLF & _
"23E+4" & @CRLF & _
"12.45E5" & @CRLF & _
"-12.34E-5i" & @CRLF & _
"4.948601281E-4-11.34E-4i"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")