using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ \t]*(\+|\-)?[ \t]*(\d*\.?\d+(E[\+|\-|\d]\d*)?)";
string input = @"4.948601281E-4
34.6
12
23E+4
12.45E5
-12.34E-5i
4.948601281E-4-11.34E-4i";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}