const regex = /[ \t]*(\+|\-)?[ \t]*(\d*\.?\d+(E[\+|\-|\d]\d*)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ \\t]*(\\+|\\-)?[ \\t]*(\\d*\\.?\\d+(E[\\+|\\-|\\d]\\d*)?)', 'g')
const str = `4.948601281E-4
34.6
12
23E+4
12.45E5
-12.34E-5i
4.948601281E-4-11.34E-4i`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}