package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[ \t]*(\+|\-)?[ \t]*(\d*\.?\d+(E[\+|\-|\d]\d*)?)`)
var str = `4.948601281E-4
34.6
12
23E+4
12.45E5
-12.34E-5i
4.948601281E-4-11.34E-4i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}