$re = '/[ \t]*(\+|\-)?[ \t]*(\d*\.?\d+(E[\+|\-|\d]\d*)?)/';
$str = '4.948601281E-4
34.6
12
23E+4
12.45E5
-12.34E-5i
4.948601281E-4-11.34E-4i';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);