re = /^(?:(?!ab|cd)(.))+$/m
str = 'This text won\\\'t match because it does contain ab in it!
This text won\\\'t match because it does contain cd in it!
This text matches because it doesn\\\'t contain them in itghdfgdfg!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end