using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!ab|cd)(.))+$";
string input = @"This text won\'t match because it does contain ab in it!
This text won\'t match because it does contain cd in it!
This text matches because it doesn\'t contain them in itghdfgdfg!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}