$re = '/^(?:(?!ab|cd)(.))+$/m';
$str = 'This text won\\\'t match because it does contain ab in it!
This text won\\\'t match because it does contain cd in it!
This text matches because it doesn\\\'t contain them in itghdfgdfg!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);