#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!ab|cd)(.))+$"
Local $sString = "This text won\'t match because it does contain ab in it!" & @CRLF & _
"" & @CRLF & _
"This text won\'t match because it does contain cd in it!" & @CRLF & _
"" & @CRLF & _
"This text matches because it doesn\'t contain them in itghdfgdfg!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")