import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!ab|cd)(.))+$";
final String string = "This text won\\'t match because it does contain ab in it!\n\n"
+ "This text won\\'t match because it does contain cd in it!\n\n"
+ "This text matches because it doesn\\'t contain them in itghdfgdfg!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}