const regex = /^(?:(?!ab|cd)(.))+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!ab|cd)(.))+$', 'gm')
const str = `This text won\\'t match because it does contain ab in it!
This text won\\'t match because it does contain cd in it!
This text matches because it doesn\\'t contain them in itghdfgdfg!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}