import Foundation
let pattern = #"(^ATech::[^\|]+)(?:\|\|)(POC::[^\|]+)(?:\|\|)(SvcT::[^\|]+)(?:\|\|)(TicP::[^\|]+)(?:\|\|)(Note::.+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ATech::1398626148121005@mil||POC::1061890773121005@mil||SvcT::195||TicP::P2||Note::Working"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)