using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^ATech::[^\|]+)(?:\|\|)(POC::[^\|]+)(?:\|\|)(SvcT::[^\|]+)(?:\|\|)(TicP::[^\|]+)(?:\|\|)(Note::.+$)";
string input = @"ATech::1398626148121005@mil||POC::1061890773121005@mil||SvcT::195||TicP::P2||Note::Working";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}