package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^ATech::[^\|]+)(?:\|\|)(POC::[^\|]+)(?:\|\|)(SvcT::[^\|]+)(?:\|\|)(TicP::[^\|]+)(?:\|\|)(Note::.+$)`)
var str = `ATech::1398626148121005@mil||POC::1061890773121005@mil||SvcT::195||TicP::P2||Note::Working`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}