$re = '/(^ATech::[^\|]+)(?:\|\|)(POC::[^\|]+)(?:\|\|)(SvcT::[^\|]+)(?:\|\|)(TicP::[^\|]+)(?:\|\|)(Note::.+$)/m';
$str = 'ATech::1398626148121005@mil||POC::1061890773121005@mil||SvcT::195||TicP::P2||Note::Working';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);