import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^ATech::[^\\|]+)(?:\\|\\|)(POC::[^\\|]+)(?:\\|\\|)(SvcT::[^\\|]+)(?:\\|\\|)(TicP::[^\\|]+)(?:\\|\\|)(Note::.+$)";
final String string = "ATech::1398626148121005@mil||POC::1061890773121005@mil||SvcT::195||TicP::P2||Note::Working";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}