const regex = /(^ATech::[^\|]+)(?:\|\|)(POC::[^\|]+)(?:\|\|)(SvcT::[^\|]+)(?:\|\|)(TicP::[^\|]+)(?:\|\|)(Note::.+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^ATech::[^\\|]+)(?:\\|\\|)(POC::[^\\|]+)(?:\\|\\|)(SvcT::[^\\|]+)(?:\\|\\|)(TicP::[^\\|]+)(?:\\|\\|)(Note::.+$)', 'gm')
const str = `ATech::1398626148121005@mil||POC::1061890773121005@mil||SvcT::195||TicP::P2||Note::Working`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}