// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)safari-extension:\/\/com\.wondershare\.ultimate-[a-zA-Z0-9]+\/[a-zA-Z0-9]+\/core\.js").unwrap();
let string = "safari-extension://com.wondershare.ultimate-yzc2t44zdx/a6e09559/core.js
safari-extension://com.wondershare.ultimate-URLID1/URLID2/core.js
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}