re = /safari-extension:\/\/com\.wondershare\.ultimate-[a-zA-Z0-9]+\/[a-zA-Z0-9]+\/core\.js/m
str = 'safari-extension://com.wondershare.ultimate-yzc2t44zdx/a6e09559/core.js
safari-extension://com.wondershare.ultimate-URLID1/URLID2/core.js
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end