package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)safari-extension:\/\/com\.wondershare\.ultimate-[a-zA-Z0-9]+\/[a-zA-Z0-9]+\/core\.js`)
var str = `safari-extension://com.wondershare.ultimate-yzc2t44zdx/a6e09559/core.js
safari-extension://com.wondershare.ultimate-URLID1/URLID2/core.js
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}