import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "safari-extension:\\/\\/com\\.wondershare\\.ultimate-[a-zA-Z0-9]+\\/[a-zA-Z0-9]+\\/core\\.js";
final String string = "safari-extension://com.wondershare.ultimate-yzc2t44zdx/a6e09559/core.js\n"
+ "safari-extension://com.wondershare.ultimate-URLID1/URLID2/core.js\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}