using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"safari-extension:\/\/com\.wondershare\.ultimate-[a-zA-Z0-9]+\/[a-zA-Z0-9]+\/core\.js";
string input = @"safari-extension://com.wondershare.ultimate-yzc2t44zdx/a6e09559/core.js
safari-extension://com.wondershare.ultimate-URLID1/URLID2/core.js
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}