#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)safari-extension:\/\/com\.wondershare\.ultimate-[a-zA-Z0-9]+\/[a-zA-Z0-9]+\/core\.js"
Local $sString = "safari-extension://com.wondershare.ultimate-yzc2t44zdx/a6e09559/core.js" & @CRLF & _
"safari-extension://com.wondershare.ultimate-URLID1/URLID2/core.js" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")