// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?#Block)
(?<block>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
(?:__
(?#Element)
(?<element>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
(?:--
(?#Modifier)
(?<modifier>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
$").unwrap();
let string = "block__element--modifier";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}