import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?#Block)\n"
+ "(?<block>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)\n\n"
+ "(?:__\n"
+ "(?#Element)\n"
+ "(?<element>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)\n"
+ ")?\n\n"
+ "(?:--\n"
+ "(?#Modifier)\n"
+ "(?<modifier>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)\n"
+ ")?\n"
+ "$";
final String string = "block__element--modifier";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}