$re = '/^
(?#Block)
(?<block>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
(?:__
(?#Element)
(?<element>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
(?:--
(?#Modifier)
(?<modifier>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
$/mx';
$str = 'block__element--modifier';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);