#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?#Block)" & @CRLF & _
"(?<block>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)" & @CRLF & _
"" & @CRLF & _
"(?:__" & @CRLF & _
"(?#Element)" & @CRLF & _
"(?<element>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)" & @CRLF & _
")?" & @CRLF & _
"" & @CRLF & _
"(?:--" & @CRLF & _
"(?#Modifier)" & @CRLF & _
"(?<modifier>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)" & @CRLF & _
")?" & @CRLF & _
"$"
Local $sString = "block__element--modifier"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")