package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(?#Block)
(?<block>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
(?:__
(?#Element)
(?<element>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
(?:--
(?#Modifier)
(?<modifier>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
$`)
var str = `block__element--modifier`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}